MEPL JD
CatalogCategoriesBrandsAnalyticsNew

MEPL JD

JD catalog demo by MEPL

Navigation

  • All Products
  • Categories
  • Brands
  • Category Analytics 📊

Tools

  • Advanced Search
  • My Favorites

Admin

  • Dashboard

© 2026 MEPL JD. All rights reserved.

Back to Catalog
Yikatong IP205C Network Telephone, 100Mbps Dual Network Port IP Phone, VOIP Network Telephone, SIP Protocol Office Phone, with Headset Interface
Thumbnail 1
Thumbnail 2
Thumbnail 3
Thumbnail 4
Thumbnail 5
•Meeting audio and video

Yikatong IP205C Network Telephone, 100Mbps Dual Network Port IP Phone, VOIP Network Telephone, SIP Protocol Office Phone, with Headset Interface

CNÂ¥238.00
SKU: 100031932426
Status:In Stock (11)
ID: 100031932426
Weight: 840.00 g
Dims:230x165x85 mm

Specifications

Type
IP Telephone
Handwriting touch
Not supported
Video conferencing is supported
Video conferencing is not supported

Variants / Sale Attributes

Color: IP205C [Adapter Power Supply]

Package Contents

1 network telephone, 1 handset, 1 power adapter, 1 base stand, 1 handset cord, 1 Ethernet cable.

Product Description

Overview

Brand
EKATO
Model
IP205
Type
Simplified Gigabit IP Phone

Features

  • Supports HD high-definition audio quality
  • Simple interface to enhance communication efficiency
  • Compatible with various systems

Keyboard Introduction

Similar Products

Out of Stock
Yijiatong Single-Ear Headset Y500-RJ9 Crystal Connector, Over-Ear Headset/customer Service Headset/noise-Cancelling Headphones/sales Call Headset/business/education Direct Connection Telephone
Meeting audio and video

Yijiatong Single-Ear Headset Y500-RJ9 Crystal Connector, Over-Ear Headset/customer Service Headset/noise-Cancelling Headphones/sales Call Headset/business/education Direct Connection Telephone

Y500 Single Ear-RJ9 Crystal Head

CNÂ¥59.00

View
Out of Stock
Jabra Evolve2 65 Flex MS Wireless Charging Pad Bluetooth Noise-Cancelling Headset for Computer Office Conference Calls Customer Service Online Education Over-Ear
JabraMeeting audio and video

Jabra Evolve2 65 Flex MS Wireless Charging Pad Bluetooth Noise-Cancelling Headset for Computer Office Conference Calls Customer Service Online Education Over-Ear

[Foldable with Base] Ev2 65MS Flex

CNÂ¥2,771.00

View
  • Speaker, Line key 1, Line key 2, Display screen, Mute key/Return key, Redial key, Customizable programmable keys, Hands-free key, Microphone, Navigation keys, Volume keys
  • Key Functions

    • PBX compatible functions
    • BLF/BLA, BLF list, Do Not Disturb, Call forwarding, Intercom, Paging, Dialing rules, Call pickup, Call waiting, Distinctive ringing, Anonymous call, Advanced features

    Advanced Features

    • Supports XML personal address book search/import/export (300 entries)
    • Supports enterprise address book (800 entries)
    • LDAP directory
    • 4 customizable programmable keys

    Network Parameters

    • SIPV1 (RFC2543), V2 (RFC3261) support
    • STUN Intranet penetration support
    • Three DTMF modes: In-band, RFC2833, SIPINFO
    • Three IP acquisition methods: Static IP/DHCP/PPPoE
    • Built-in DNS/TFTP/FTP client
    • NAT/DHCP service support
    • SIP and RTPQo support
    • Supports 2 line registrations

    Audio Parameters

    • Wideband encoding: G.722
    • Narrowband encoding: G.711U/A, G.723.1, G.726, G.729AB, ILBC
    • Supports VAD, CNG, AEC, AGC audio processing
    • Full-duplex hands-free with automatic echo cancellation

    Configuration Management

    • Supports FTP/TFTP/HTTP/HTTPS automatic updates
    • Three configuration modes: Web, phone, and automatic configuration
    • Supports TR069 protocol, Telnet management

    Security Features

    • VLAN (802.1pq), LLDP, VPN (L2TP) support
    • TLS (Transport Layer Security) protocol support
    • Supports MD5 information verification mechanism, AES encryption protocol/SRTP protocol support
    • Keyboard lock/supports administrator/user hierarchical mode
    In Stock
    HION U800 Call Center Telephone Recording Equipment Recording Telephone Set for Operators Customer Service Landline Recording Telephone Box Computer Dialing (For Fixed-Line Telephone Lines)
    HIONMeeting audio and video

    HION U800 Call Center Telephone Recording Equipment Recording Telephone Set for Operators Customer Service Landline Recording Telephone Box Computer Dialing (For Fixed-Line Telephone Lines)

    U800 (Fixed-Line Connection)

    CNÂ¥429.00

    View
    In Stock
    Logitech H340 [Enterprise-Grade] Over-Ear Stereo USB Headset for Computer, Laptop, Office And Study with Microphone, Black [Order Bonus]
    LogitechMeeting audio and video

    Logitech H340 [Enterprise-Grade] Over-Ear Stereo USB Headset for Computer, Laptop, Office And Study with Microphone, Black [Order Bonus]

    [H340] Black

    CNÂ¥109.00

    View